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Создание отчетов в МатЛАБ 
 

Цель работы: освоение процесса построения отчетов в автоматическом режиме в 

МатЛАБ. 

Задача работы:  построение отчета с помощью пакета MatLAB Report Generator. 

Приборы и принадлежности: Персональный компьютер, интегрированная среда 

МатЛАБ, компилятор TexLive. 

 

 

ОБЩИЕ СВЕДЕНИЯ 

 

Генератор отчетов (Report Generator) позволяет легко создавать стандартные и 

пользовательские отчеты из MatLAB, Simulink и Stateflow в различных форматах, включая 

HTML, RTF, XML и SGML. Можно автоматически документировать работу сложных 

систем, создавая множество шаблонов для передачи информации. Отчеты могут 

содержать любую информацию, доступную в рабочем пространстве MatLAB, включая 

данные, переменные, функции, программы MatLAB, модели и диаграммы. Можно 

включать в отчет рабочие экраны или графики, сгенерированные с помощью m-файлов 

или моделей. 

Имеется два вида генератора отчетов:   

• MatLAB Report Generator представляет собой средство для создания отчетов из 
MatLAB m-файлов.  

• Simulink Report Generator, требующий для своей работы MATLAB Report 
Generator, обеспечивает дополнительные возможности для создания отчетов из 

моделей Simulink и Stateflow. 

Управлять генератором отчетов можно  

• через MATLAB Report Explorer (вызывается командой >> report, пример генерации 

отчета через Report Explorer дан иже в Задании 3), 
• через графический интерфейс пользователя (GUI) или  

• из командной строки MATLAB (вызывается командой >> publish).  

•  

Подготовка отчета на cell уровне.  

Часто m-файлы имеют структуру, состоящую из нескольких разделов (секций). Работа с 

большими файлами представляет собой работу с его фрагментами как при описании и 

отладке кода, так и при перемещении фрагментов одного m-файла в другой. Для 

упрощения этих процессов, документирования и презентации кода и его результатов 

исходный файл можно разбить на секции cells которыми обозначаются разделы m-файла. 

Вот список Cell функций меню m-файла: 

1. Для включения / выключения режима разбиения документа на секции используются 

команды Cell >  Enable Cell Mode / Cell >  Disable Cell Mode. При включении режима в 

меню m-файла появляется следующая панель инструментов 

. Скрыть / восстановить панель 



инструментов можно нажатием правой клавиши мыши на панели инструментов m-

файла и выбором “Cell Toolbar” в выпадающем меню.  

2. Границы разделов обозначаются двойным процентом %% который устанавливается 

вводом с клавиатуры в начале первой строки раздела или командой меню Cell > Insert 

Cell Divider (или Insert Cell Break) или кнопкой меню . Изменить фон выделенной 

секции можно командами раздела File > Preferences > Editor/Debugger > Cell display 

options. Название секции (раздела) должно следовать через пробел за двойным 

процентом %%. Оно автоматически выделяется жирным шрифтом. 

Примечание:  

• Горизонтальные линии, разделяющие секции m-файла, не видны при печати 
файла.  

• В строках, начинающихся двойным процентом %% код не выполняется 

• MatLAB воспринимает строку выше первой началом секции. 

• Установку % в начале нескольких строк можно выполнить выделением строк и 
нажатием <Ctrl+R>, а удаление процента в начале нескольких строк – 

выделением строк и нажатием <Ctrl+T> 

• Цвета выделения секции можно задать в разделе Cell Display options меню m-
файла > File > Preferences > Colors > Programming Tools. 

• Режим редактора “Enable integrated warning and error messages” 

(устанавливается в  Меню редактора > File > Preferences > Code Analyzer) 

позволяет обеспечить наглядное автоматическое отображение строк m-файла, 

содержащих синтаксические ошибки.  

 

3. После определения границ разделов можно использовать быстрый переход от секции 

к секции (кнопка ). Переход от одной секции к другой можно выполнить также и 
командами меню > Cell > Next Cell / Previous Cell или Crtl + Down / Ctrl + Up. 

 

4. Для установки типа секции используется набор команд 



 который раскрывается ниже. 

4.1. Функция Cell > Insert Text Markup > Document Title and Introduction вставляет в m-фйл 

шаблон  DOCUMENT TITLE и INTRODUCTORY TEXT которые необходимо 

заменить собственным названием документа. Ниже, слева представлена часть m-

файла, а справа – соответствующий фрагмент HTML отчета. 

   �    

Название документа автоматически попадает в раздел Table of Contents (оглавление 

отчета)  

4.2.Функция Section Title with Cell Break и Section Title Without Cell Break вставляет в m-

фйл шаблон названия раздела и его описание с разделителем раздела (with Cell Break) 

или без него (Without Cell Break). Текст шаблона необходимо заменить собственным 

вариантом.  

  �   

      �    

Название раздела автоматически попадает в раздел Table of Contents (оглавление 

отчета). Если первая строка секции с %% не содержит текст, то эта секция не 

обозначается в оглавлении отчета. 



 

�  

4.3.Команды Bold, Italic, и Monospaced Text изменяют шрифты как показано ниже 

  �   

Символы торговых марок обозначаются в отчете следующим образом:  

   �     

4.4.Hyperlinks. В отчеты HTML, XML, и Microsoft Word можно включать гиперссылки  

 �   

Можно задавать динамические гиперссылки для запуска кода, когда пользователь 

щелкает гиперссылку. Пример включения гиперссылки в отчет показан ниже. 

 �   

4.5.Inline LaTeX Math Equations позволяет включить в отчет математические выражения 

MatLAB в естественном виде, например, 

     �   

4.6.Preformatted Text вставляет в отчет предварительно отформатированный текст 

обычного шрифта, с белыми пробелами и без переноса длинных строк.  

    �   

 

 

 

 



4.7. Syntax Highlighted Sample Code позволяет вставить в отчет невыполняемый m-код в 

оригинальном виде, например, 

 �   

отображение оригинального кода и его результата набирается, например, как 

   �    

4.8. Команда Cell > Insert Text Markup > External Graphics используется для вставки  

графического объекта в отчет. Для этого необходимо указать путь к объекту вместо 

записи FILENAME.PNG, например, если изображение best_road.jpg находится в папке 

images которая находится в папке с m-файлом отчета, то путь выглядит так: 
../images/best_road.jpg 

�   �    

Примечание: в отчеты doc, html, latex, ppt, xml можно вставлять любые объекты, 

которые поддерживают эти форматы. В отчет формата pdf можно включать только 

bmp и jpg объекты.  

4.9. Bulleted or Numbered Lists. Маркированные или нумерованные списки в отчете 

создаются  следующим образом. 

   �     

     �     

4.10.  HTML Markup вставляет HTML код в m-файл отчета: 

 �   

 

 



4.11.  LaTeX Markup формирует текстовый tex-файл на  языке TeX (язык 

форматирования текста) для создания высококачественных математических 

документов. 

     �     

  �  

  

Примечание:  

• Многие научные издательства требуют документы в латексе. Бесплатный 
компилятор с языка TeX / LaTeX, программу для составления документов в Tex 

формате и просмотра div-файлов “Tex Live” можно загрузить с сайта 

http://www.tug.org/texlive/. По умолчанию программа устанавливается в каталог 

с:\texlive\2012. 

• При запуске tex-файла сгенерированного, например, командой publish МатЛАБ; 
Tex Live открывает tex-файл, а также автоматически создает и открывает отчет в 

pdf формате.  

4.12. LaTeX Display Math позволяет, используя LaTeX код, включить в отчет 

математические выражения в естественном виде, например,  

      �    

4.13. Команду Force a Snapshot of Output можно использовать для циклического вывода 

изображений (figure), например,  

   �    

 

 

 

 

 

 



5. Для управления разделами документа можно пользоваться следующими кнопками 

 

6. Для изменения значения переменной секции необходимо указать на эту переменную и 

нажать на соответствующие клавиши меню: . Новое 

значение переменной появляется в workspace и на на графике секции если она связана 

с ним непосредственно или косвенно.  

7. Удалить секцию кода (с сохранением самого кода) можно удалением 

• одного процента в начале секции;  

• границы секции - строки с двумя процентами в ее начале. 

8. Построение отчета по кодам m-файла выполняется командой publish которая имеет 

следующие формат: 

>> publish(FILE) – сохраняет код, комментарии и результаты в HTML файле под тем 

же именем. HTML файл с другими вспомогательными файлами помещается в 

поддиректории "html" текущего каталога. Пример: publish(report_example.m). 

>> publish(FILE,FORMAT) сохраняет результаты в одном из следующих форматов.  

       'html'  - HTML. 

       'doc'   - Microsoft Word (для этого формата требуется Microsoft Word). 

       'pdf'   - PDF. 

       'ppt'   - Microsoft PowerPoint (требуется Microsoft PowerPoint). 

       'xml'   - XML file может быть создан с помощью XSLT или других инструментов. 

       'latex' - LaTeX.   

 

Примечание. В html формате отчет можно построить и по команде меню m-файла Publish 

to HTML: . Эта команда также запускает Web Browser который открывает 

отчет. 

Аннотирование файлов упрощает поиск областей кода. Аннотация начинается 

комментарием % TODO, %  FIXME и % NOTE. Отчет TODO/FIXME позволят выявить в 

текущей папке все MatLAB файлы с аннотациями и определить номера строк с 

аннотациями. Запуск отчета по содержанию аннотаций в m-файлах выполняется 

следующим образом.  

 



ПРИМЕРЫ ПОЛУЧЕНИЯ ПРОВЕРЕННЫХ РЕЗУЛЬТАТОВ И ВАРИАНТЫ ДЛЯ 
САМОКОНТРОЛЯ 

 

Задание 1. Посекционная обработка m-файла. 

1. Наберите следующий m-код.  
% Define the range for x. 
% Calculate and plot y = sin(x). 
x = 0:1:6*pi; 
y = sin(x); 
plot(x,y) 
title('Sine Wave','FontWeight','bold') 
xlabel('x') 
ylabel('sin(x)') 
set(gca,'Color','w') 
set(gcf, 'MenuBar', 'none') 

2. Выберите режим меню m-файла: Cell > Enable Cell Mode 

3. Введите заголовок секции Calculate and plot y = sin(x). первой строкой файла. 

 

4. Обозначьте следующую секцию перед строкой title как заголовок Modify Plot 

Properties 

 

5. Сохраните файл. 

6. Наблюдайте за изменениями в файле удаляя/вставляя один процент из %% или строку 

с двумя процентами.  

7. Для наглядного отображения ошибок скрипта установите “Enable integrated warning 

and error messages”  в  Меню редактора > File > Preferences > Code Analyzer.  

 

8. Введите в код синтаксическую ошибку, например, квадратную скобку:  

 

Обратите внимание как MatLAB указывает на ошибку в коде. 



9. В текущем каталоге создайте новый m-файл fourier.m со следующим кодом.  
function fourier 
    t = 0:.1:pi*4; 
    y = sin(t); 
    updatePlot(1,t,y); 
     
    for k = 3:2:9 
        y = y + sin(k*t)/k; 
        display(sprintf('When k = %.1f',k));          
    end 
end 
 
function updatePlot(k,t,x) 
    cla 
    plot(t,x) 
     
end 

10. Вставьте два разделителя секций: 

• один внутри функции Фурье, на линии 5, 

• один в цикле - в строке 8. 

11. Установите маркер снаружи кода функции fourier, например, на линии 13. 

 

Выделение всего файла показывает секцию первого уровня. 

12. Выделите секцию второго уровня - установите маркер в функции fourier снаружи 

цикла. 

 или  

13. Выделите секцию третьего уровня - установите маркер в цикл функции fourier. 

 



14. Для создания секции включающей весь код подфункции установите марке в строку 

function и вставьте разделитель секции . 

15. Несколько раз перейдите от одной секции к другой используя команды меню > Cell > 

Next Cell (<Ctrl + Up>) / Previous Cell (<Ctrl + Down>). 

16. Выполните переход к секции при помощи команды меню > Go > Go To (<Ctrl + G >) 

17. Выполните коды отдельных секций. Для этого  

• командой clear all очистите Workspace; 

• поставьте маркер во вторую строку и командой  (или меню > Cell > Evaluate 
> Current > Cell или <Ctrl + Enter>) запустите секцию на выполнение; 

• посмотрите на содержимое Workspace и окна команд; 

• установите маркер на секции цикла и запустите ее; 

• найдите изменения в Workspace и окне команд. 

18. Выполните переход к секции при помощи команды меню . 

19. Запустите m-файл командой меню >Debug > Run, или <F5>, или . Запомните вид 
построенного графика.  

20. Поставьте маркер во вторую строку на инкремент переменной t и измените ее 

значение командами :  

 

21. Снова запустите m-файл. Найдите изменения на графике.  
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22. Закомментируйте несколько строк кода программы командой <Ctrl+R> затем верните 

код в исходное состояние командой <Ctrl+T>. 

 

 

Задание 2. Создание отчета. 

1. В текущей директории создайте каталог images и html. 

2. В папке html создайте  папку img 

3. Положите свой jpg файл в папку images, присвойте ему имя best_road.jpg. 

 

 



4. В текущей директории создайте m-файл, например, report_example.m. Включите в 

него следующий скрипт. 

%% DOCUMENT TITLE 
% INTRODUCTORY TEXT 
%% SECTION TITLE 
% DESCRIPTIVE TEXT 
%% 
% Cells with empty names are not included into the contain. 
% After the report description it is easy to insert the comments, for example: 
% "The report contains the formulas, please see the report version in the file 
% <report_example.pdf report_example.pdf>". 
  
% this file: report_example.m 
% data file: 
% 
% for i = 1:10 
%   disp x 
% end 
%  
%% 
% *BOLD TEXT* _ITALIC TEXT_ |MONOSPACED TEXT| 
% 
% *Define* the _range_ for |x| 
% 
% Tools(TM) software(R) 
% 
%% 
% <http://www.mathworks.com MathWorks> 
%% Recycling Preference 
% Click the preference you want: 
% 
% <matlab:recycle('off') Disable recycling> 
% 
% <matlab:recycle('on') Enable recycling> 
%% 
% $x^2+e^{\pi i}$ 
%% 
%  
%  Preformatted text line 1. 
%  TEXT 
%  
%% Sample code 
%  The following is an example of the FOR statement.  
% 
%   for i = 1:10 
%       disp x 
%   end 
%  
% The DISP function runs: 
  
disp ('Executable code') 
  
%% 
%  
% * ITEM1 
% * ITEM2 
% 
%% 
%  
% # ITEM1  
% # ITEM2 
%  



  
%% 
% This is picture  
% 
% <<../images/best_road.jpg>> 
%  
%% 
%  
% <html> 
% <table border=1><tr><td>one</td><td>two</td></tr></table> 
% </html> 
%  
%% 
%  
% <latex> 
% \begin{tabular}{|c|c|} \hline 
% $n$ & $n!$ \\ \hline 
% 1 & 1 \\ 
% 2 & 2 \\ 
% 3 & 6 \\ \hline 
% \end{tabular} 
% </latex> 
%  
%% 
%  
% $$e^{\pi i} + 1 = 0$$ 
%  
for i=1:3 
    imagesc(magic(i)) 
    snapnow; 
end 
%% Theory  
% To install the teg LaTex,it needs to open new cell. 
%% 
% <latex> 
% It is descussed the calculation of the following function $y = sin(x)$ and 
% in is prooved that  
% $$\int\limits_{-\infty}^{\infty} sin(x) dx = 0.$$ 
% </latex> 
  
%% Experiment of computing 
% The test, its purpose and method are described here Here. It is better tp write  
% notes in English 
  
% $$ 
% If the section begins with comments, please separate the comments by 
% empty line. 
N = 182; 
x = linspace(... 
datenum('1/1/200700:00:00'),... 
datenum('6/1/200700:00:00'),N); 
y = cos(x*2*pi/N); 
h = figure; hold on 
plot(x,y,'r-'); 
plot(x,y,'r.'); 
datetick('x','m'); 
axis tight 
legend('solar history'); 
xlabel('date'); 
ylabel('altitude'); 
% please insert the break line here to correct the plot manually 
% create the folder 'html/img/' in necessary 
saveas(h,'html/img/solar','png'); % to the html report 



saveas(h,'html/img/solar','psc2'); % to the LaTeX report 
% please comment the 'saveas' lines to keep corrected plots unchanged 
close(h); 
%% 
% <<img/solar.png>> 
%% 
% Conclusion: The plot shows sin function. 
  
%% 
% To include the plot into the LaTeX report, it needs to change  
% .png by .ps in txt-file. 

5. Построение отчета выполните командой publish, например, 

>> publish (‘report_example’,’html’) 

6. Используя другие опции команды publish постройте отчет в формате 'doc' (для этого 

формата требуется Microsoft Word); 'pdf'; 'ppt' - Microsoft PowerPoint (требуется 

Microsoft PowerPoint); 'xml' - XML file может быть создан с помощью XSLT или 

других инструментов; 'latex'. 

7. Сравните фрагменты отчетов и соответствующие коды m-файла.  

 

 

Задание 3. Пример генерации отчета через Report Explorer 

1. Запустите Report Explorer, набрав в окне команд >>report. 

 

 

 

 



2. Cоздайте установочный (setup) файл отчета Unnamed.rpt: File > New.  

 

3. Справа в Report Options установите директорию Present …  из списка. 

. 

4. Выберите тип отчета: html  .  

5. Дайте следующее описание отчета . 

6. Сохраните отчет под именем magic_squares.rpt: File > Save As. 

 

7. Укажите на rpt компонент: . 

8. Выберите компонент Evaluate MATLAB Expression: . 

9. Выберите добавить компонент в отчет . 

10. Чтобы исключить появление кода и содержимого окна команд МатЛАБ в отчете 

снимите соответствующие флажки: . 

11. Очистите окно Expression to evaluate in the base workspace и разместите там 

следующий текст. 



%This MATLAB code sets up two variables 
%that define how the report runs. 
%magicSizeVector is a list of MxM 
%Magic Square sizes to insert into 
%the report. Note that magic 
%squares cannot be 2x2. 
 
magicSizeVector=[4 8 16 32]; 
 
%largestDisplayedArray sets the 
%limit of array size that will be 
%inserted into the report with the 
%Insert Variable component. 
 
largestDisplayedArray=15; 

Очистите окно Evaluate this expression if there is an error и разместите там текст:  

disp(['Error during eval: ', evalException.message]) 

В результате должно получиться следующее. 

. 

12. Сохраните отчет: File > Save. 

13. Для создания титульной страницы дважды щелкните по объекту: . 



В результате появится объект: . 

14. Выберите и заполните следующие зоны: 

. 

15. В раздел введение (Abstract) введите текст An introduction to Magic Squares and their 

meaning:   . 

16. Сохраните отчет: File > Save. 

17. Выберите Title Page компонент . 

18. Для включения главы дважды щелкните по следующему объекту: 

. 

В результате структура принимает вид: . 

19. Для включения введения дважды щелкните по объекту: . 

20. Укажите на следующую строку: . 



21. Дважды щелкните по следующему объекту: . 

22. Укажите на строку: . 

23. Дважды щелкните по объекту Text как в п.22 выше. 

24. Выберите первый Text компонент:  . 

25. Введите текст %<help('magic')>: . 

26. Выберите второй Text - <No Text> компонент. 

27. Как в п.26 введите следующий текст: 

The German artist Albrecht Durer (1471-1528) created many woodcuts and prints with religious and scientific 
symbolism.  One of his most famous works, Melancholia I, explores the depressed state of mind that opposes 
inspiration and expression. Renaissance astrologers believed that the Jupiter magic square (shown in the 
upper right portion of the image) could aid in the cure of melancholy. The engraving's date (1514) can be found 
in the lower row of numbers in the square.  

28. Сохраните отчет: File > Save. 

29. На левой панели укажите на компонент Chapter:  

30. На средней панели дважды щелкните по объекту 

Evaluate: . 

31. Переместите вниз компонент Eval: . Для этого 

используйте команду объекта Eval. 



32. Снимите следующие флажки: . 

33. В окне Expression to evaluate in the base workspace оставьте только следующий код 

МатЛАБ. 

%This loads a self-portrait of Albrecht 
%Durer, a German artist. There is a 
%magic square in the upper right corner 
%of the image. 
 
durerData=load('durer.mat','-mat'); 
figure('Units','Pixels',... 
'Position',[200 200 size(durerData.X,2)*.5 size(durerData.X,1)*.5 ]); 
 
image(durerData.X); 
colormap(durerData.map); 
axis('image'); 
set(gca,... 
    'Xtick',[],... 
    'Ytick',[],... 
    'Units','normal',... 
    'Position',[0 0 1 1]); 
 
clear durerData 

34. Очистите окно Evaluate expression if there is an error и включите туда текст: 

disp(['Error during eval: ', evalException.message]) 

35. Дважды щелкните по следующему объекту: . 

36. Установите выделенные свойства: . 

37. Дважды щелкните по объекту Evaluate: . В результате левая 

панель примет вид . 

 

 



38. Снимите флажки и вставьте следующий код:  

%This command deletes the Durer image 
delete(gcf);  

 

39. Очистите окно Evaluate expression if there is an error и включите туда текст: 

disp(['Error during eval: ', evalException.message]) 

40. Сохраните отчет: File > Save. 

41. На левой панели укажите на компонент Chapter.  

42. На средней панели дважды щелкните по объекту For loop: 

. 

43. Переместите вниз компонент for: . Для этого 

используйте команду объекта for. 

44. Установите следующие свойства: . В левой панели строка for 

примет вид: . 

45. Сохраните отчет: File > Save. 

46. В левой панели укажите на объект for. 

47. В средней панели дважды щелкните по следующему 

объекту.  

48. Введите следующее название главы Magic Square # %<MAGIC_SQUARE_INDEX>  

 



49. Сохраните отчет: File > Save. 

50. На левой панели укажите на компонент Chapter – Magic Square.  

51. Дважды щелкните по объекту: . 

52. Очистите указанные зоны:  

53. Очистите окно Expression to evaluate in the base workspace и вставьте текст: 

magic_Square_Size=magicSizeVector(MAGIC_SQUARE_INDEX); 

54. В окне Evaluate expression if there is an error замените текст на следующий. 

disp(['Error during eval: ', evalException.message]) 

В результате конец структуры левой панели примет вид      

   

55. Сохраните отчет: File > Save. 

56. Дважды щелкните по объекту:  

57. В левой панели укажите на строку: . 

58. Дважды щелкните по объекту:  

59. Введите имя переменной:  

В результате объект левой панели примет вид:  

60. Сохраните отчет: File > Save. 

61. В левой панели укажите на нижнюю строку Paragraph.  

62. Дважды щелкните по объекту:  

63. В левой панели переместите созданный компонент Eval вниз командой . 

64. Очистите указанные зоны:  

65. Очистите окно Expression to evaluate in the base workspace и вставьте МатЛАБ код: 

%This MATLAB script produces a magic 
%square of size magic_Square_Size 
%and creates an image of that square. 



 
mySquare=magic(magic_Square_Size); 
clf 
imagesc(mySquare); 
title(sprintf('Magic Square N=%i',magic_Square_Size)) 
set(gca,'Ydir','normal'); 
axis equal; 
axis tight; 

66. В окне Evaluate expression if there is an error замените текст на следующий. 

disp(['Error during eval: ', evalException.message]) 

67. Сохраните отчет: File > Save.  

68. Укажите на Eval компонент  

69. Дважды щелкните по объекту: . 

70. В окне Text Expression правой панели замените текст на следующий. 
magic_Square_Size<=largestDisplayedArray 

71. Укажите на if компонент левой панели . 

72. Дважды щелкните по объекту: . 

73. Снова укажите на if компонент левой панели. 

74. Дважды щелкните по объекту: . 

Должна получиться структура  

75. Дважды щелкните по объекту: . 



76. В правую панель внесите следующие изменения: . 

77.  В левой панели укажите на компонент else. 

78. Дважды щелкните по объекту: . 

79. В левой панели укажите на  . 

80. Дважды щелкните по объекту:  

81. В правую панель внесите следующие изменения: 

 

82. Сохраните отчет: File > Save. 

Вид левой панели для контроля: .  

Отчет содержит все необходимые компоненты 

83. Постройте отчет командой . 

Открывшееся окно Message List содержит детали построения отчета: 



  

Начало созданного отчета выглядит следующим образом: 

 

84. В Report Explorer рассмотрите связи между элементами структуры Setup файла 

magic_squares.rpt и элементами отчета magic_squares.html. 

85. В левой панели укажите на , в свойствах объекта 

установите формат:  и постройте отчет в pdf формате 

командой . 

 

Задание 4. Генерация отчета собственной работы работы. 

1. В среде MatLAB сгенерируйте полный отчет собственной работы. В отчете 

используйте английский язык поскольку текст на русском языке может отображаться 

некорректно.  

Примечание.  

• Генератор отчетов позволяет управлять проектированием путем выбора из 
множества встроенных установочных файлов (setup) или созданием собственных 

файлов. Можно переместить компонент из списка в свой установочный файл, 

изменить порядок компонентов, а также изменять атрибуты компонентов и 

форматирование. Форматирование управляется при помощи стилей. Можно 

использовать несколько встроенных стилей таблиц для каждого типа документа 

или создать таблицу своего стиля. Можно управлять макетом (layout) страницы, 

используемым шрифтом, отображением таблицы, содержимым заголовка, 



содержимым таблицы, заголовком презентации, и многим другим. Установочные 

файлы и стили страниц могут копироваться и использоваться повторно. 

• Официально русский язык в МАТЛАБ не поддерживается. Но для ряда версий 

системных операционных сред и МатЛАБ нормальное отображение кириллицы, 

возможно, можно обеспечить, руководствуясь следующими советами 

(http://matlab.exponenta.ru/forum/viewtopic.php?t=4572): 

В MATLAB 7.2 и старше для нормального отображений кириллицы необходимо 

использовать только кодировку windows-1251.  

slCharacterEncoding('windows-1251')  

При этом для использования кириллицы на фигурах, необходимо, либо явно 

указать кириллический шрифт:  

title('Россия','FontName','Arial Cyr')  

 либо установить переменную среды окружения,  

MATLAB_USE_NATIVE_FONTS = 1 (Свойства системы, Дополнительно, 

Переменные среды)  

В Simulink 6.5 (R2006b) проблема буквы «я» - решена!  

Для сохранения моделей с русским буквами используйте:  

feature('MultibyteCharSetChecking',0)  

Проблемы с кириллицей в старых релизах пакета, частично можно решить 
правкой реестра:  

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Nls\CodePage]  

 "1250"="c_1251.nls"  

 "1251"="c_1251.nls"  

 "1252"="c_1251.nls"  

В предыдущих версиях нет поддержки буквы "я". 

В английской версии Windows буквы русского алфавита отображаются 

нормально после руссификации с помощью MUI.  

2. Дополните m-код комментариями для соблюдения общего стиля написания кода в 

MATLAB 

3. Разбейте отчет на главы. 

4. Используйте в отчете логические компоненты шаблонов такие как IF, THEN, ELSE, 

или WHILE 

 

 

КОНТРОЛЬНЫЕ ВОПРОСЫ 
 

1. Каково назначение генератора отчетов? 

2. Какими средствами можно подготовить отчет по модели Simulink? 

3. Как разбить m-файл на секции (cell)? 

4. Как найти файлы и номера строк содержащие аннотации?  
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